Mozilla Thunderbird

From ITGwiki
Jump to: navigation, search
The Mozilla Thunderbird icon

Mozilla Thunderbird is ITG's email client of choice. It's robust and reliable, and is available on multiple platforms.

Contents

Common tasks

Empty the Trash

  1. Open Thunderbird
  2. Right click on the trash folder
  3. Select empty trash
Click to enlarge

Show/hide email headers

  • Show full headers
    1. In Thunderbird's menu (at the top of the window or screen), click View
    2. Point to Headers
    3. Click All
  • Hide full headers
    1. Click View
    2. Point to Headers
    3. Click Normal

Message filters

This article is a quick guide to setting up message filters in Thunderbird. Message filters can automate the handling of mail that meets pre-defined criteria.

Example

The best way to learn this is by examining an example. In our example, we'd like to automatically send all email from "Motley Fool" to the SPAM folder.

  1. In Thunderbird, click Tools, then click Message Filters...
  2. Ensure that your account is selected under Filters for:
  3. Click New..." on the right side
  4. Add search criteria in the top box
    • For our example, I set the values to Subject contains Motley Fool.
  5. Add filter actions in the bottom box
    • For our example, I set the values to Move message to SPAM on justin.
  6. Click OK
Reference images (Click to enlarge)
Step 1
Steps 2 and 3
Steps 4-6

Subscribing to folders

By default, Thunderbird may not show all of the folders in your email account. You can explicitly define which folders you'd like to see by subscribing to them.

  1. Right-click (or Control-click on a Mac) your account in the left-most pane in Thunderbird
  2. Select Subscribe...
  3. Check the folders you'd like to subscribe to. (ITG suggest subscribing to all available folders.)
  4. Click Subscribe
  5. Click OK
Steps 1 and 2 (Click to enlarge)
Steps 3 through 5 (Click to enlarge)

Using a signature

To create signatures in Thunderbird, you just need to create a text file with the signature and then tell Thunderbird that you want to use it as a signature.

Signature Template

In each of the following walk-throughs for Windows and Mac, we recommend the use the following template to create your signature.

Pat Perf
Assistant Lecturer
Gevirtz Graduate School of Education
University of California, Santa Barbara
(805) 893-0000
pperf@education.ucsb.edu

Windows instructions

  1. Open Notepad (Click Start > Run and type notepad in the box, then click OK).
  2. Make the signature. You can copy and paste the signature template in this article with changes made to reflect your own information.
  3. In the menu at the top, click File > Save As... and choose a suitable location and name for your signature.
  4. Click Save.

Mac OS X instructions

  1. Open TextEdit (in your Applications folder).
  2. In the menu at the top, click Format > Make Plain Text to switch to plain text mode.
  3. Make the signature. You can copy and paste the signature template in this article with changes made to reflect your own information.
  4. When you are done, click File > Save As... and select a suitable location and name for your signature.
  5. Click Save.

Configuring Thunderbird

Configuring a signature in Thunderbird on Mac OS X. The dialog looks similar in Windows. (Click to enlarge)
  1. In the menu at the top, click Tools > Account Settings. You'll see a dialog like the one to the right.
  2. Select your account.
  3. Check Attach this signature.
  4. Click Choose and browse to the file that you created. Select the file and click Open.
  5. Click OK.

Local folders

Local folders can be made to sort your email in Thunderbird.

  1. In the column on the left, Right-click (or Control-click on a Mac) Local Folders.
  2. Select New Folder.
  3. Name the folder how you would like it.
  4. Select one or more messages and Right-click (or Control-click on a Mac) them and select Move To.
  5. You can also drag and drop messages.

Disable Tabs

  1. On Mac, open Thunderbird->Preferences->Advanced->Reading & Display->Open messages in: and check A new message window.
  2. On Windows, open Tools->Options->Advanced->Reading & Display->Open messages in: and check A new message windows.
  3. Now go back to the General tab under the Advanced tab and click Config Editor.... If you get a warning, just acknowledge it and continue.
  4. In the filter field type "autohide" and look for the entry mail.tabs.autoHide.
  5. Double-click the field until the false column changes to true.

Disable automatically moving junk mail

Is Thunderbird automatically moving or deleting messages that are marked as junk when you don't want it to? Follow these instructions (or watch the following video), and Thunderbird will only mark messages as junk (it will not delete or move them).

  1. Click Tools → Account Settings...
  2. Select your account
  3. Select Junk Settings
  4. Uncheck the Move new junk messages to: box
  5. Click OK

FAQ

Q. Thunderbird is acting funny. What do I do?
A. Just restart Thunderbird. If it continues to act funny, delete the panacea.dat file from your Thunderbird profile. This is sort of a cure-all. :)
Q. Where does Thunderbird store my mail, contacts, and other data?
A. In your Thunderbird profile. See Mozilla Thunderbird/profile for more details.
Q. When I compose an email, instead of my signature, I see a bunch of nonsense symbols or nothing at all. Why?
A. Your signature file may have been moved or deleted, or may not be plain text. Create a new signature following the steps on the the signature page.
Q. My address book is gone (usually after a crash or power failure), how can I restore it?
A. Close Thunderbird completely, open your profile folder (Start>Run>"%APPDATA%/Thunderbird/Profiles" on Windows, /Users/username/Library/Thunderbird/Profiles on Mac) and open one of the cryptically named folders, there is probably only one. You should see abook.mab and abook.mab.bak. Move abook.mab to your desktop and rename abook.mab.bak to abook.mab. Open Thunderbird and your address book should be back.
Q. My Thunderbird updated automatically overnight and now it has annoying tabs! How can I disable this and make things more like old Thunderbird?
A. First go to Tools (Preferences on Mac) > Options > Advanced > Reading and Display and change the Open Messages in setting to either a new or existing window. Now go to the General tab to the left and click the Config editor button. It may warn you about a warranty, but you're safe to continue. In the filter bar type autohide, you should be left with one entry mail.tabs.autoHide. Double-click it so that the value column changes to true. Close the config editor and you're done.
Q. When I try to send a message I get an error message saying that I have reached my quota and cannot save anymore emails. What do I do?
A. There are two options to take into consideration.
  1. You have too many emails saved in your inbox and sent folder, try deleting the old ones you don't need anymore.
  2. Contact ITG Help Desk to see if they will increase you quota for mail storage on the server.

Troubleshooting

Migration problems

When moving mail folders manually, discard the *.msf files. They aren't necessary for the migration, and can cause strange behavior.

Directory certificate is not trusted

If you're seeing this, check out our directory certificate not trusted page.

If you get an error message while typing an email address that reads directory.education.ucsb.edu:636 uses an invalid security certificate and reports Error code: sec_error_expired_issuer_certificate, check out directory certificate not trusted.

Recreate profile

Sometimes, something in Thunderbird is broken and you just can't figure out what it is. The simplest solution is to recreate the profile.

  1. Export address book to a file
  2. Quit Thunderbird
  3. Rename Thunderbird profile folder to Thunderbird.bak
  4. Open Thunderbird and create a new account
  5. Import address book from file
  6. Quit Thunderbird
  7. Copy Mail folder from Thunderbird.bak profile into your new profile
  8. Start Thunderbird and see if everything looks good

External links

Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox